Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
efi_x86_64_ipxe get ipv6 ip always time out
2015-12-23, 03:15
Post: #1
Sad efi_x86_64_ipxe get ipv6 ip always time out

1. I setup ipxe server for datacenter. In the IPv4 environment the test system will boot into LiveOS successfully. However it will fail in IPv6 environment. Test system can get IPv6 ip in the PXE and can download ipxe.efi file. After Ipxe initial device, it can’t get IPv6 ip and always connection timed out.

We had try below methods
a. Disable cisco spanning tree mod
b. Using wireshark to log package, test system send correct DUID to server
c. Direct connect server and test system 10G sfp, it was still fail.
d. Use newest ipxe source code to build ipxe.efi.
e. Using the error message to search in the Web, however the solation was used in IPv4 environment

We had checked the ipxe driver support list, our device was supported. The card we use is Intel-x520-DA1. The most confused us was it was workable in the IPv4 environment. Because my dhcpd6 send IPv6 ip need more 30 sec to send IPv6 IP, but the ipxe was time out about 20 sec. I can't find out any surce code or configure to increase dhcp IPv6 time out sec.

Could you check the messages, is there anything we missing?

Below was the information when we build ipxe

a.The command using when I build ipxe.efi. I has enable "NET_PROTO_IPV6"
#cd /ipxe/src/
#make bin-x86_64-efi/ipxe.efi EMBED=ipxescriptfile

b.My embedded ipxe script <ipxescriptfile>
dhcp || ifconf -c ipv6 || ifconf -c dhcp net0 ||goto retry

time initrd http://[fc80::4]/initramfs.img
time kernel http://[fc80::4]/vmlinuz root=live:http://[fc80::1]/squashfs.img rootfstype=auto ro liveimg nodiskmount nolvmmount rd.luks=0 keymap=us lang=en_US text console=ttyS0,57600n8 debug crashdump=128M initrd=\initramfs.img


c. My error message capture from test server
>>Checking Media Presence......
>>Media Present......
>>Start PXE over IPv6..
Station IP address is FC80:0:0:0:0:0:1Big Grin
Server IP address is FC80:0:0:0:0:0:0:4
NBP filename is ipxe.efi
NBP filesize is 872128 Bytes

>>Checking Media Presence......
>>Media Present......
Downloading NBP file...

Succeed to download NBP file.
iPXE initialising devices...ok

iPXE 1.0.0+ -- Open Source Network Boot Firmware --
Features: DNS HTTP TFTP EFI Menu
Configuring (net0 90:e2:ba:a3:f1:20) ........................... Error 0x040ee186 (
Waiting for link-up on net0 ... ok
Configuring [ipv6] (net0 90:e2:ba:a3:f1:20) .................. Connection timed out (
Waiting for link-up on net0 ... ok
Configuring [dhcp] (net0 90:e2:ba:a3:f1:20) ................................................ Connection timed out (
Find all posts by this user
Quote this message in a reply
2016-11-02, 10:40
Post: #2
RE: efi_x86_64_ipxe get ipv6 ip always time out
Are you sure that your router advertisement daemon is running (radvd on Linux) and handing out a proper IPv6 subnet? That is required as far as I know for your DHCPv6 server to be used for either address or PXE options to be delivered.

Also check the counters (ifstat) to ensure that you're actually receiving responses to your configuration requests. Worst case scenario you can try to configure a static address and route to verify if the issue is RA or DHCPv6 responses. Also try to build with debug enabled for dhcp and RA. Find the .c file which contains the code you're unsure if works and add DEBUG=dhcp,slaac to the make command line if your .c files are named dhcp.c and slaac.c.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 

User(s) browsing this thread: 1 Guest(s)