Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Background not work on Microsoft VirtualPC
2016-04-03, 09:48
Post: #1
Background not work on Microsoft VirtualPC
Because latest iPXE build not work in rom-o-matic.eu and in Linux i use iPXE from 2 March. I tested also the old version {png} Add support for PNG images. Both versions do not work in MS VPC 2007.
Command:
Code:
console -p dog.png
fails with the error: http://ipxe.org/err/2d8c203b
[Image: 7981142.png]
After build DEBUG=vesafb:3 have error:
[Image: 7809978m.png]
I tested different resolutions and different file type e.g. ipxe.pgm but still the same error.

vesamenu.c32 from PXELINUX work OK:
[Image: 7987305m.png]
Find all posts by this user
Quote this message in a reply
2016-04-03, 10:00
Post: #2
RE: Background not work on Microsoft VirtualPC
(2016-04-03 09:48)Gelip Wrote:  Because latest iPXE build not work in rom-o-matic.eu and in Linux i use iPXE from 2 March. I tested also the old version
{png} Add support for PNG images. Both versions do not work in MS VPC 2007.
Command:
Code:
console -p dog.png
fails with the error: http://ipxe.org/err/2d8c203b
[Image: 7981142.png]

The error in the image tells you that the code is to old (if the link is followed).
ipxe.org/2d8c203b Wrote:This error most likely means the console command was unable to find a usable resolution in the VESA BIOS mode list.
You can compile your binary with DEBUG=vesafb to get a list of which resolutions was detected when running the console command.

This is a known issue in MS Hyper-V there might have been a patch available to get around this.
It should however work on real hardware, I would recommend using double pipe at the end of console so that the script won't terminate just due to failed terminal change:
Code:
console -p dog.png ||

Read FAQ before first post!
Are relevant ipxe.org error urls and PCIIDs included?
Visit this user's website Find all posts by this user
Quote this message in a reply
2016-04-03, 11:13
Post: #3
RE: Background not work on Microsoft VirtualPC
(2016-04-03 10:00)NiKiZe Wrote:  I would recommend using double pipe at the end of console so that the script won't terminate just due to failed terminal change:
Code:
console -p dog.png ||
Yes, this is a workaround a problem, no background but script still work thx Smile
(2016-04-03 10:00)NiKiZe Wrote:  It should however work on real hardware.
Unfortunately, the background does not work well on some real hardware e.g. GeForce2 MX400 with latest iPXE. Fortunately, the older version {png} Add support for PNG images works well Shy
[Image: 7964781m.gif]
Find all posts by this user
Quote this message in a reply
2016-04-03, 11:17
Post: #4
RE: Background not work on Microsoft VirtualPC
Compile with DEBUG=vesafb and post output so this can be debugged.

Read FAQ before first post!
Are relevant ipxe.org error urls and PCIIDs included?
Visit this user's website Find all posts by this user
Quote this message in a reply
2016-04-03, 11:31 (This post was last modified: 2016-04-04 08:13 by Gelip.)
Post: #5
RE: Background not work on Microsoft VirtualPC
(2016-04-03 11:17)NiKiZe Wrote:  Compile with DEBUG=vesafb and post output so this can be debugged.
OK, but now something is wrong with the latest code iPXE and I build failures on rom-o-matic.eu and on Linux Undecided
Latest iPXE error build by Gelip
I'll wait until the code is improved and begin a new topic.
Find all posts by this user
Quote this message in a reply
2016-04-04, 18:09
Post: #6
RE: Background not work on Microsoft VirtualPC
(2016-04-03 11:31)Gelip Wrote:  
(2016-04-03 11:17)NiKiZe Wrote:  Compile with DEBUG=vesafb and post output so this can be debugged.
OK, but now something is wrong with the latest code iPXE and I build failures on rom-o-matic.eu and on Linux Undecided
Latest iPXE error build by Gelip
I'll wait until the code is improved and begin a new topic.

Reading your error messages it seems something with the infiniband driver set is failing on your build. I have no idea why, but do you actually need infiniband built into your iPXE binaries?

If not, edit the src/config/general.h file and comment or undef the IBMGMT_CMD line. I'd recommend just commenting it as it's leaves less chance of a typo.

The line number would be 124.
Visit this user's website Find all posts by this user
Quote this message in a reply
2016-04-04, 18:17
Post: #7
RE: Background not work on Microsoft VirtualPC
(2016-04-03 11:31)Gelip Wrote:  OK, but now something is wrong with the latest code iPXE and I build failures on rom-o-matic.eu and on Linux Undecided
Latest iPXE error build by Gelip
I'll wait until the code is improved and begin a new topic.

It's more likely an error at rom-o-matic, you might want to try and build localy, and if local builds fail, please post that buildlog with error so we can try and help you solve that issue.

Read FAQ before first post!
Are relevant ipxe.org error urls and PCIIDs included?
Visit this user's website Find all posts by this user
Quote this message in a reply
2016-04-04, 21:31
Post: #8
RE: Background not work on Microsoft VirtualPC
(2016-04-04 18:09)mastacontrola Wrote:  If not, edit the src/config/general.h file and comment or undef the IBMGMT_CMD line. I'd recommend just commenting it as it's leaves less chance of a typo.

The line number would be 124.
This not help
(2016-04-04 18:17)NiKiZe Wrote:  It's more likely an error at rom-o-matic, you might want to try and build localy, and if local builds fail, please post that buildlog with error so we can try and help you solve that issue.
localy build fail
Find all posts by this user
Quote this message in a reply
2016-04-04, 21:35 (This post was last modified: 2016-04-04 21:37 by NiKiZe.)
Post: #9
RE: Background not work on Microsoft VirtualPC
(2016-04-04 21:31)Gelip Wrote:  localy build fail
Code:
[HOSTCC] util/zbin
util/zbin.c:7:18: error: lzma.h: No such file or directory
....
make: *** [util/zbin] Error 1
root@debian:/ipxe/src#


From: http://lists.ipxe.org/pipermail/ipxe-dev...03998.html
Code:
> util/zbin.c:7:18: error: lzma.h: No such file or directory

You need to install liblzma-dev.

Read FAQ before first post!
Are relevant ipxe.org error urls and PCIIDs included?
Visit this user's website Find all posts by this user
Quote this message in a reply
2016-04-04, 22:06 (This post was last modified: 2016-04-04 23:29 by Gelip.)
Post: #10
RE: Background not work on Microsoft VirtualPC
Yes, after install liblzma-dev build locally OK but latest iPXE also make the same mistakes as I wrote in the first post:

http://ipxe.org/2d8c203b - No such file or directory
http://ipxe.org/1d8c2139 - Function call failed
Find all posts by this user
Quote this message in a reply
2016-04-05, 20:57
Post: #11
RE: Background not work on Microsoft VirtualPC
(2016-04-04 22:06)Gelip Wrote:  latest iPXE also make the same mistakes as I wrote in the first post:

http://ipxe.org/2d8c203b - No such file or directory
http://ipxe.org/1d8c2139 - Function call failed

Actually, it is your BIOS that does not support any of the VESA modes. (or atleast not as iPXE is trying to use it) as stated before it is known that Microsoft Hyper-V does not support VESA

Output from DEBUG=vesafb (I now see you edited your first post) shows you http://ipxe.org/1d8c2139 which tells where it fails, hopefully someone with Hyper-V can come up with a fix.

But for now, VESA won't work in Microsoft Hyper-V (sorry if I lead you to believe otherwise, but with the image above it might have given more info about the issue)

Read FAQ before first post!
Are relevant ipxe.org error urls and PCIIDs included?
Visit this user's website Find all posts by this user
Quote this message in a reply
2016-04-05, 21:42
Post: #12
RE: Background not work on Microsoft VirtualPC
(2016-04-05 20:57)NiKiZe Wrote:  (I now see you edited your first post) shows you http://ipxe.org/1d8c2139
I not edited the post - rather you did not notice
(2016-04-05 20:57)NiKiZe Wrote:  Actually, it is your BIOS that does not support any of the VESA modes. (or atleast not as iPXE is trying to use it) as stated before it is known that Microsoft Hyper-V does not support VESA
MS VPC 2007 support VESA, look one more time on my first post - and screenshot from vesamenu.c32.
I test also vbeprobe tool in GRUB4DOS:
[Image: 7954208m.png]
Find all posts by this user
Quote this message in a reply
2016-04-06, 10:47 (This post was last modified: 2016-04-07 06:38 by Gelip.)
Post: #13
RE: Background not work on Microsoft VirtualPC
I found PCI BIOS S3 - S3 86C375/86C385 Video BIOS. Version 2.01.16.M45 Everything works without a problem - background iPXE and vesamenu.c32. Tested also OS's WinXP, GRUB4DOS, Debian and BIOS does not cause any problems Cool
Code:
iPXE 1.0.0+ (5975) -- Open Source Network Boot Firmware -- http://ipxe.org
Features: DNS HTTP iSCSI TFTP SRP AoE ELF MBOOT PXE bzImage Menu PXEXT

iPXE> dhcp
Configuring (net0 00:03:ff:44:32:89).... ok
iPXE> console -p dog.png
dog.png... ok
VESAFB saved VGA mode 0x03
VESAFB found VBE version 2.0 with mode list at c000:0d16
VESAFB mode 4109 132x25 4bpp(0:0:0:0) model 00 [x64] [tty] [text] [nonlinear]
VESAFB mode 410a 132x43 4bpp(0:0:0:0) model 00 [x64] [tty] [text] [nonlinear]
VESAFB mode 412e 320x200 8bpp(0:0:0:0) model 04 [x64]
VESAFB mode 410d 320x200 15bpp(1:5:5:5) model 06 [x32]
VESAFB mode 410e 320x200 16bpp(0:5:6:5) model 06 [x32]
VESAFB mode 410f 320x200 32bpp(8:8:8:8) model 06 [x16]
VESAFB mode 4131 320x240 8bpp(0:0:0:0) model 04 [x32]
VESAFB mode 4132 320x240 15bpp(1:5:5:5) model 06 [x21]
VESAFB mode 4133 320x240 16bpp(0:5:6:5) model 06 [x21]
VESAFB mode 4134 320x240 32bpp(8:8:8:8) model 06 [x12]
VESAFB mode 4141 400x300 8bpp(0:0:0:0) model 04 [x32]
VESAFB mode 4142 400x300 15bpp(1:5:5:5) model 06 [x16]
VESAFB mode 4143 400x300 16bpp(0:5:6:5) model 06 [x16]
VESAFB mode 4144 400x300 32bpp(8:8:8:8) model 06 [x8]
VESAFB mode 4151 512x384 8bpp(0:0:0:0) model 04 [x21]
VESAFB mode 4152 512x384 15bpp(1:5:5:5) model 06 [x10]
VESAFB mode 4153 512x384 16bpp(0:5:6:5) model 06 [x10]
VESAFB mode 4154 512x384 32bpp(8:8:8:8) model 06 [x5]
VESAFB mode 4100 640x400 8bpp(0:0:0:0) model 04 [x16]
VESAFB mode 411c 640x400 15bpp(1:5:5:5) model 06 [x8]
VESAFB mode 411d 640x400 16bpp(0:5:6:5) model 06 [x8]
VESAFB mode 411e 640x400 32bpp(8:8:8:8) model 06 [x4]
VESAFB mode 4101 640x480 8bpp(0:0:0:0) model 04 [x12]
VESAFB mode 4110 640x480 15bpp(1:5:5:5) model 06 [x6]
VESAFB mode 4111 640x480 16bpp(0:5:6:5) model 06 [x6]
VESAFB mode 4112 640x480 32bpp(8:8:8:8) model 06 [x3]
VESAFB mode 4102 800x600 4bpp(0:0:0:0) model 03 [x16] [tty] [nonlinear]
VESAFB mode 4103 800x600 8bpp(0:0:0:0) model 04 [x8]
VESAFB mode 4113 800x600 15bpp(1:5:5:5) model 06 [x4]
VESAFB mode 4114 800x600 16bpp(0:5:6:5) model 06 [x4]
VESAFB mode 4115 800x600 32bpp(8:8:8:8) model 06 [x2]
VESAFB mode 4104 1024x768 4bpp(0:0:0:0) model 03 [x8] [nonlinear]
VESAFB mode 4105 1024x768 8bpp(0:0:0:0) model 04 [x5]
VESAFB mode 4116 1024x768 15bpp(1:5:5:5) model 06 [x2]
VESAFB mode 4117 1024x768 16bpp(0:5:6:5) model 06 [x2]
VESAFB mode 4118 1024x768 32bpp(8:8:8:8) model 06 [x1]
VESAFB mode 4161 1152x864 8bpp(0:0:0:0) model 04 [x4]
VESAFB mode 4162 1152x864 15bpp(1:5:5:5) model 06 [x2]
VESAFB mode 4163 1152x864 16bpp(0:5:6:5) model 06 [x2]
VESAFB mode 4164 1152x864 32bpp(8:8:8:8) model 06 [x1]
VESAFB mode 4106 1280x1024 4bpp(0:0:0:0) model 03 [x5] [nonlinear]
VESAFB mode 4107 1280x1024 8bpp(0:0:0:0) model 04 [x3]
VESAFB mode 4119 1280x1024 15bpp(1:5:5:5) model 06 [x1]
VESAFB mode 411a 1280x1024 16bpp(0:5:6:5) model 06 [x1]
VESAFB mode 4120 1600x1200 8bpp(0:0:0:0) model 04 [x2]
VESAFB selected mode 4115
VESAFB mode 4115 800x600 32bpp(8:8:8:8) model 06 [x2]
VESAFB mode 4115 has frame buffer at f8000000
VESAFB has font 0600 at c000:69f0

iPXE>
Find all posts by this user
Quote this message in a reply
2016-04-06, 12:29
Post: #14
RE: Background not work on Microsoft VirtualPC
(2016-04-04 21:31)Gelip Wrote:  
(2016-04-04 18:09)mastacontrola Wrote:  If not, edit the src/config/general.h file and comment or undef the IBMGMT_CMD line. I'd recommend just commenting it as it's leaves less chance of a typo.

The line number would be 124.
This not help
(2016-04-04 18:17)NiKiZe Wrote:  It's more likely an error at rom-o-matic, you might want to try and build localy, and if local builds fail, please post that buildlog with error so we can try and help you solve that issue.
localy build fail

While I'm glad you're able to operate with pictures and vesamenu.c32, in regards to the quoted message, what didn't work? Building failed in a different point? Is infiniband still built into your binaries or did you remove it and the error you had after this was in regards to liblzma-dev package not being installed?

I am only trying to help understand what and where things are going wrong. I'm not trying to lead you into a wrong direction or anything. When you say "it didn't help" says to me that it failed at the same point? Really it gives almost NO information at all.
Visit this user's website Find all posts by this user
Quote this message in a reply
2017-03-01, 16:12 (This post was last modified: 2017-03-01 16:24 by Gelip.)
Post: #15
RE: Background not work on Microsoft VirtualPC
(2016-04-06 12:29)mastacontrola Wrote:  I am only trying to help understand what and where things are going wrong. I'm not trying to lead you into a wrong direction or anything. When you say "it didn't help" says to me that it failed at the same point? Really it gives almost NO information at all.
In 2013, I encountered for the first time with iPXE and use Debian Squeeze for locally build. Then enough to install these packages:
  • apt-get install git
  • apt-get install build-essential
  • apt-get install syslinux
  • apt-get install genisoimage
but iPXE since version Sat, 21 Feb 2015 16:29:53 +0200 {zbin} Use LZMA compression requires additional package:
  • apt-get install liblzma-dev
That's all Cool

I also found another BIOS S3 which operates iPXE background: 1-s3vgdx.bin




Alternative BIOS'es work but there are some minor problems with GRUB in graphics mode. When you start the Debian Live in graphics mode e.g. vga=789 800x600 is a black screen during:
  • 3,05 minutes when VGA bios is 86c375_3.bin
  • 4,05 minutes when VGA bios is 1-s3vgdx.bin
In text mode, I have not noticed any problems Smile

Debian terminal console installed on disk in graphics mode have problem clear/refresh screen:
[Image: 8001941m.gif]
I found it: GRUB gfxpayload
Quote:Depending on your kernel, your distribution, your graphics card, and the phase of the moon, note that using this option may cause GNU/Linux to suffer from various display problems, particularly during the early part of the boot sequence. If you have problems, set this variable to ‘text’ and GRUB will tell Linux to boot in normal text mode.

To resolve this problem simply need increase GRUB menu timeout from 5 to 6 seconds:
Code:
    nano /etc/default/grub

    change GRUB_TIMEOUT=5 to 6
    
    update-grub
    reboot
Strange, but one second helps Huh

Other problems have not noticed. Any operating system is working properly Cool

Probably replacing VGA BIOS can also be used in Hyper-V
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)