Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ipxe initialisinge devices
2019-06-03, 19:04
Post: #1
ipxe initialisinge devices
Hello !
On my desktop (which has 2 network interfaces, 1 intel and 1 atheros), I remain stuck on "ipxe initialising devices" on either of the network interfaces.
I don't have this problem on other computers or on virtual machines.
I tried at least 4 versions of ipxe but still the same problem.
Can you help me?
Thanks!
Find all posts by this user
Quote this message in a reply
2019-06-03, 20:41
Post: #2
RE: ipxe initialisinge devices
It is hard to help you without more information.

Please always include which iPXE binary you are using. (for example ipxe.efi, undionly.kpxe etc)

Also include pciids for the devices.

Read FAQ before first post!
Are relevant ipxe.org error urls and PCIIDs included?
Visit this user's website Find all posts by this user
Quote this message in a reply
2019-06-04, 11:53
Post: #3
RE: ipxe initialisinge devices
I use ipxe.efi.
Where do I find the "pciids"?
Thanks!
Find all posts by this user
Quote this message in a reply
2019-06-06, 08:06 (This post was last modified: 2019-06-08 16:46 by NiKiZe.)
Post: #4
RE: ipxe initialisinge devices
pciids are preferably found by using lspci -nn in linux

you could try snp.efi and see if it makes any difference, but you will probably have to dig into building ipxe.efi with some DEBUG= flags enabled to figure out why it hangs, not sure what at the moment since we don't know exactly which drivers are involved.

Read FAQ before first post!
Are relevant ipxe.org error urls and PCIIDs included?
Visit this user's website Find all posts by this user
Quote this message in a reply
2019-06-08, 15:25
Post: #5
RE: ipxe initialisinge devices
Why do you need the DEBUG= flags enabled for this btw, NiKiZe?
Find all posts by this user
Quote this message in a reply
2019-06-10, 10:40
Post: #6
RE: ipxe initialisinge devices
(2019-06-08 15:25)Naquin Wrote:  Why do you need the DEBUG= flags enabled for this btw, NiKiZe?

With DEBUG flags, there will be more logs.
Find all posts by this user
Quote this message in a reply
2019-06-10, 15:15
Post: #7
RE: ipxe initialisinge devices
I was able to recover the pci :

00:00.0 Host bridge [0600]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor DRAM Controller [8086:0150] (rev 09)
00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port [8086:0151] (rev 09)
00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04)
00:16.0 Communication controller [0780]: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 [8086:1e3a] (rev 04)
00:19.0 Ethernet controller [0200]: Intel Corporation 82579V Gigabit Network Connection [8086:1503] (rev 04)
00:1a.0 USB controller [0c03]: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 [8086:1e2d] (rev 04)
00:1b.0 Audio device [0403]: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller [8086:1e20] (rev 04)
00:1c.0 PCI bridge [0604]: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 [8086:1e10] (rev c4)
00:1c.1 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 [8086:1e12] (rev c4)
00:1c.5 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev c4)
00:1c.6 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 7 [8086:1e1c] (rev c4)
00:1c.7 PCI bridge [0604]: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 8 [8086:1e1e] (rev c4)
00:1d.0 USB controller [0c03]: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 [8086:1e26] (rev 04)
00:1f.0 ISA bridge [0601]: Intel Corporation Z77 Express Chipset LPC Controller [8086:1e44] (rev 04)
00:1f.2 SATA controller [0106]: Intel Corporation 7 Series/C210 Series Chipset Family 6-port SATA Controller [AHCI mode] [8086:1e02] (rev 04)
00:1f.3 SMBus [0c05]: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller [8086:1e22] (rev 04)
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti PRO [Radeon HD 7950/8950 OEM / R9 280] [1002:679a]
01:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti HDMI Audio [Radeon HD 7870 XT / 7950/7970] [1002:aaa0]
03:00.0 SATA controller [0106]: Marvell Technology Group Ltd. 88SE9172 SATA 6Gb/s Controller [1b4b:9172] (rev 11)
04:00.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev 30)
05:01.0 FireWire (IEEE 1394) [0c00]: VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller [1106:3044] (rev c0)
06:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0)
07:00.0 SATA controller [0106]: Marvell Technology Group Ltd. 88SE9172 SATA 6Gb/s Controller [1b4b:9172] (rev 11)


But I do not know what to do with it ...

For the debug flags, can you describe in detail how to proceed?

Thanks !
Find all posts by this user
Quote this message in a reply
2019-06-10, 19:43
Post: #8
RE: ipxe initialisinge devices
Cutting that down ...
(2019-06-10 15:15)bluedark Wrote:  00:19.0 Ethernet controller [0200]: Intel Corporation 82579V Gigabit Network Connection [8086:1503] (rev 04)
06:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0)

But I do not know what to do with it ...

For the debug flags, can you describe in detail how to proceed?

Thanks !

Now we can check which drivers that relates to in iPXE, and from that decide suggested DEBUG flags, I don't have the time to dig into that right now tho, sorry, will try to get back to you ASAP

Read FAQ before first post!
Are relevant ipxe.org error urls and PCIIDs included?
Visit this user's website Find all posts by this user
Quote this message in a reply
2019-06-11, 12:50
Post: #9
RE: ipxe initialisinge devices
OK, thanks. I am waiting for your return. In the meantime, has anyone ever encountered this problem and may be able to help me?
Find all posts by this user
Quote this message in a reply
Post Reply 




User(s) browsing this thread: 1 Guest(s)