The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 807 - File: showthread.php PHP 7.3.15 (Linux)
File Line Function
/showthread.php 807 errorHandler->error

Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HP DL380 Gen10 Error: 0xc0000001
2019-06-01, 00:55 (This post was last modified: 2019-06-01 01:10 by dzeleski.)
Post: #1
HP DL380 Gen10 Error: 0xc0000001
I have other hardware booting with the exact same setup. We are using MDT and chaining directly to MDTs litetouchpe image. Specifically on these HP DL380 gen10 servers we get an error:

BlInitializeLibrary failed 0xc0000001

Whats interesting is that the output between this server and a working server are nearly the same minus the memory addresses. I tried injecting HPs drivers into the PE image and that did not work, tried different BCD files that also did not work, also tried using copype and using the files it created and that did not work. Out of ideas at this point and that error is pretty not helpful :/


[Image: Uv9zjkd.png]


Using latest wimboot and latest ipxe

BCD looks like this:
PS D:\DeploymentShare\Boot\x64\Boot> bcdedit /store BCD /enum all

Windows Boot Manager
identifier              {bootmgr}
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
default                 {default}
displayorder            {default}
toolsdisplayorder       {memdiag}
timeout                 30

Windows Boot Loader
identifier              {default}
device                  ramdisk=[boot]\sources\boot.wim,{7619dcc8-fafe-11d9-b411-000476eba25f}
path                    \windows\system32\boot\winload.exe
description             Windows Setup
locale                  en-US
inherit                 {bootloadersettings}
osdevice                ramdisk=[boot]\sources\boot.wim,{7619dcc8-fafe-11d9-b411-000476eba25f}
systemroot              \windows
custom:250000c2         1
detecthal               Yes
winpe                   Yes
ems                     No

Windows Memory Tester
identifier              {memdiag}
device                  boot
path                    \boot\memtest.exe
description             Windows Memory Diagnostic
locale                  en-US
inherit                 {globalsettings}

EMS Settings
identifier              {emssettings}
bootems                 No

Debugger Settings
identifier              {dbgsettings}
debugtype               Serial
debugport               1
baudrate                115200

Global Settings
identifier              {globalsettings}
inherit                 {dbgsettings}

Boot Loader Settings
identifier              {bootloadersettings}
inherit                 {globalsettings}

Hypervisor Settings
identifier              {hypervisorsettings}
description             Hypervisor Settings
hypervisordebugtype     Serial
hypervisordebugport     1
hypervisorbaudrate      115200

Device options
identifier              {7619dcc8-fafe-11d9-b411-000476eba25f}
ramdisksdidevice        boot
ramdisksdipath          \boot\boot.sdi
PS D:\DeploymentShare\Boot\x64\Boot>

ipxe script:

kernel http://<url>/DeploymentShare/Boot/x64/Boot/wimboot
initrd http://<url>/DeploymentShare/Boot/x64/Boot/BCD BCD
initrd http://<url>/DeploymentShare/Boot/x64/Boot/boot.sdi boot.sdi
initrd -n boot.wim http://<url>/DeploymentShare/Boot/LiteTouchPE_x64.wim boot.wim
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
HP DL380 Gen10 Error: 0xc0000001 - dzeleski - 2019-06-01 00:55

User(s) browsing this thread: 1 Guest(s)