The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 807 - File: showthread.php PHP 7.3.15 (Linux)
File Line Function
/showthread.php 807 errorHandler->error

Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
iPXE install of KVM VPS leaves VNC hung
2019-12-04, 07:40
Post: #1
iPXE install of KVM VPS leaves VNC hung
On several KVM VPSes from various vendors, I hit ^B in the VNC console on
SolusVM and install an image from Recently I bought a new VPS
and found that after Ctrl-Alt-Reset, the VNC console doesn't pause for ^B but
plows ahead trying to boot from disk and CD-ROM. The vendor tells me they
don't support custom ISOs.

After some digging around, I ran across this script:

This worked great for me. I substituted the kernel (.lkrn) file, and
was able to install whatever I wanted. Everything works normally, SSH access,
rebooting, etc.

After rebooting, I tried to use the VNC console, and it is frozen with one line
on the screen:

/dev/vda1: clean, 65503/2621449 files, 1224852/10485248 blocks

The Ctrl-Alt-Del button will reboot the machine, but there is no effect from any
other keystrokes. After a supported reinstall, the VNC console boots into a
login prompt.

Is there anything I might fix to keep the VNC function after an iPXE install?
Any ideas how to debug what is stuck? I'd ask the hosting company, but, of
course, they don't support custom ISOs... I don't think I can use this custom
installation method if I have to give up the error recovery options via the VNC
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
iPXE install of KVM VPS leaves VNC hung - disarli - 2019-12-04 07:40

User(s) browsing this thread: 1 Guest(s)