Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
2013-07-26, 00:36
Post: #1

I was trying to chain boot an efi image.
My setup is all like traditional PXE with snponly.efi as the PXE file.

While chainloading an EFI file, I always fail at last_opened_snpdev() as it internally tries to find a PCI SNP device which it does not find. Is the problem here itself ??

Or what I understood that this can be the case as this is a software interface with no PCI address. To fix that I tried installing the protocols onto a new handle (initially NULL) and then loading the image, however the image never finds any files to read. So I tried doing this on the efi_image_handle itself. And this failed again with none of these protocols even being found on the device handle of the new image.

Any suggestions??

Find all posts by this user
Quote this message in a reply
2013-07-26, 13:04
Post: #2
RE: efi_image_exec
UEFI support is still not complete. I suggest you discuss this issue on the developer mailing-list.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 

User(s) browsing this thread: 1 Guest(s)