Post Reply 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Broadcom BCM5709 cards not working
2016-03-23, 13:04 (This post was last modified: 2016-03-23 13:05 by SebastianRoth.)
Post: #8
RE: Broadcom BCM5709 cards not working
(2016-03-22 18:34)skibumatbu Wrote:  Thanks. lets hope a developer reads this and can take a look. Should I repost this in the developer forum/mailing list?
The developers are more active on the IRC channel I think. Give that a try if you like. But I am sure they will read this here as well.

(2016-03-22 18:34)skibumatbu Wrote:  I am running in legacy bios mode. When I try undionly, I get a "Try to free Memory without Signature" error. I don't see alot of information on how to resolve that in google.
Searching the web for that error I found this very intersting discussion: (as well read through the linked mailing list topic: ) Unfortunately the gist is that UNDI won't work for the BCM5709 (14e4:1639) NIC...

Trying to investigate a little more you might want to add some debugging to see which drivers are being notified:
diff --git a/src/net/netdevice.c b/src/net/netdevice.c
index b834c3c..cf870f8 100644
--- a/src/net/netdevice.c
+++ b/src/net/netdevice.c
@@ -121,8 +121,10 @@ static void netdev_notify ( struct net_device *netdev ) {
        struct net_driver *driver;

        for_each_table_entry ( driver, NET_DRIVERS ) {
-               if ( driver->notify )
+               if ( driver->notify ) {
+                       DBGC( netdev , "Notifying '%s'\n" , driver->name );
                        driver->notify ( netdev );
+               }
Here is what it looks like when I run this in a virtual machine (QEMU):

My net0 comes up (link up) even before I run 'ifopen net0'! As well you might want to keep an eye on the NIC LED to see if link is up or down or coming up when you do 'ifopen'!

Another idea I had. What if the hang occurs due to a received packet instead of some background thing going on. Connect you host to a dump mini switch which is not further connected to your LAN. Then see what happens when you 'ifopen net0'. Keep an eye on the LED...
Find all posts by this user
Quote this message in a reply
Post Reply 

Messages In This Thread
RE: Broadcom BCM5709 cards not working - SebastianRoth - 2016-03-23 13:04

User(s) browsing this thread: 1 Guest(s)